// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\bhp\b).*(\blaptop\b)|(\blaptop\b).*(\bhp\b)").unwrap();
let string = "I have hp laptop
I have a laptop
I have laptop made by HP
I have a fleshpot laptop";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}