using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bhp\b).*(\blaptop\b)|(\blaptop\b).*(\bhp\b)";
string input = @"I have hp laptop
I have a laptop
I have laptop made by HP
I have a fleshpot laptop";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}