re = /(\bhp\b).*(\blaptop\b)|(\blaptop\b).*(\bhp\b)/i
str = 'I have hp laptop
I have a laptop
I have laptop made by HP
I have a fleshpot laptop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end