#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:https?|ftps?|file)://(*SKIP)(*F)|//"
Local $sString = "http://example.com///" & @CRLF & _
"http://emy.dod.com/ka///skaa/dkaiad/amaa//////////" & @CRLF & _
"http://www.example.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")