$re = '/(?:https?|ftps?|file)://(*SKIP)(*F)|///';
$str = 'http://example.com///
http://emy.dod.com/ka///skaa/dkaiad/amaa//////////
http://www.example.com/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);