re = /(?:https?|ftps?|file):\/\/(*SKIP)(*F)|\/\//
str = 'http://example.com///
http://emy.dod.com/ka///skaa/dkaiad/amaa//////////
http://www.example.com/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end