const regex = /(?:https?|ftps?|file)://(*SKIP)(*F)|///;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?|ftps?|file):\/\/(*SKIP)(*F)|\/\/', '')
const str = `http://example.com///
http://emy.dod.com/ka///skaa/dkaiad/amaa//////////
http://www.example.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}