// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:https?|ftps?|file)://(*SKIP)(*F)|//").unwrap();
let string = "http://example.com///
http://emy.dod.com/ka///skaa/dkaiad/amaa//////////
http://www.example.com/";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}