#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/([a-z-]+)-([0-9]+[AB]?)/([a-z0-9-]+)-([a-z0-9]+)\.html"
Local $sString = "http://alloemploi.fr/haute-vienne-87/pole-emploi-anpe-de-saint-junien-779.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")