import Foundation
let pattern = #"/([a-z-]+)-([0-9]+[AB]?)/([a-z0-9-]+)-([a-z0-9]+)\.html"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://alloemploi.fr/haute-vienne-87/pole-emploi-anpe-de-saint-junien-779.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}