$re = '@/([a-z-]+)-([0-9]+[AB]?)/([a-z0-9-]+)-([a-z0-9]+)\.html@';
$str = 'http://alloemploi.fr/haute-vienne-87/pole-emploi-anpe-de-saint-junien-779.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);