// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/([a-z-]+)-([0-9]+[AB]?)/([a-z0-9-]+)-([a-z0-9]+)\.html").unwrap();
let string = "http://alloemploi.fr/haute-vienne-87/pole-emploi-anpe-de-saint-junien-779.html";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}