re = /\/([a-z-]+)-([0-9]+[AB]?)\/([a-z0-9-]+)-([a-z0-9]+)\.html/
str = 'http://alloemploi.fr/haute-vienne-87/pole-emploi-anpe-de-saint-junien-779.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end