using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^0{2}-2{2}(-([0-9a-fA-F]){2}){4}$)";
string input = @"00-22-64-a6-c4-20";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}