const regex = /(^0{2}-2{2}(-([0-9a-fA-F]){2}){4}$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^0{2}-2{2}(-([0-9a-fA-F]){2}){4}$)', '')
const str = `00-22-64-a6-c4-20`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}