$re = '/(^0{2}-2{2}(-([0-9a-fA-F]){2}){4}$)/';
$str = '00-22-64-a6-c4-20';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);