package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^0{2}-2{2}(-([0-9a-fA-F]){2}){4}$)`)
var str = `00-22-64-a6-c4-20`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}