import Foundation
let pattern = #"(^0{2}-2{2}(-([0-9a-fA-F]){2}){4}$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"00-22-64-a6-c4-20"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}