#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[^=\n]+$)(?!(?s).*^\1\s*=)"
Local $sString = "a" & @CRLF & _
"b" & @CRLF & _
"c" & @CRLF & _
"d" & @CRLF & _
"e" & @CRLF & _
"f" & @CRLF & _
"g" & @CRLF & _
"h" & @CRLF & _
"i" & @CRLF & _
"j" & @CRLF & _
"k" & @CRLF & _
"l" & @CRLF & _
"" & @CRLF & _
"a=dc" & @CRLF & _
"ca=ref" & @CRLF & _
"d=23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")