import re
regex = re.compile(r"(^[^=\n]+$)(?!(?s).*^\1\s*=)", flags=re.MULTILINE)
test_str = ("a\n"
"b\n"
"c\n"
"d\n"
"e\n"
"f\n"
"g\n"
"h\n"
"i\n"
"j\n"
"k\n"
"l\n\n"
"a=dc\n"
"ca=ref\n"
"d=23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")