using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^=\n]+$)(?!(?s).*^\1\s*=)";
string input = @"a
b
c
d
e
f
g
h
i
j
k
l
a=dc
ca=ref
d=23";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}