import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^=\\n]+$)(?!(?s).*^\\1\\s*=)";
final String string = "a\n"
+ "b\n"
+ "c\n"
+ "d\n"
+ "e\n"
+ "f\n"
+ "g\n"
+ "h\n"
+ "i\n"
+ "j\n"
+ "k\n"
+ "l\n\n"
+ "a=dc\n"
+ "ca=ref\n"
+ "d=23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}