#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(,)(?!.*,)"
Local $sString = "This is a text with a lot of , and then there are some , but i need to remove only last, ," & @CRLF & _
"" & @CRLF & _
"MULTIPOLYGON((xxx)),((yyy)),((zzz)),"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)