re = /(,)(?!.*,)/m
str = 'This is a text with a lot of , and then there are some , but i need to remove only last, ,
MULTIPOLYGON((xxx)),((yyy)),((zzz)),'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result