$re = '/(,)(?!.*,)/m';
$str = 'This is a text with a lot of , and then there are some , but i need to remove only last, ,
MULTIPOLYGON((xxx)),((yyy)),((zzz)),';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;