import Foundation
let pattern = #"(,)(?!.*,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This is a text with a lot of , and then there are some , but i need to remove only last, ,
MULTIPOLYGON((xxx)),((yyy)),((zzz)),
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)