using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,)(?!.*,)";
string substitution = @"";
string input = @"This is a text with a lot of , and then there are some , but i need to remove only last, ,
MULTIPOLYGON((xxx)),((yyy)),((zzz)),";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}