#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b@[\d.]*\d"
Local $sString = "jsesc@1.3.0 [license(s): MIT]" & @CRLF & _
"package.json: MIT" & @CRLF & _
"" & @CRLF & _
"json-schema@0.2.3 [license(s): AFLv2.1, AFLv2.1/BSD, BSD]" & @CRLF & _
"package.json: AFLv2.1, AFLv2.1/BSD, BSD" & @CRLF & _
"readme files: BSD" & @CRLF & _
"" & @CRLF & _
"json-schema-traverse@0.3.1 [license(s): MIT]" & @CRLF & _
"package.json: MIT" & @CRLF & _
"license files: MIT" & @CRLF & _
"" & @CRLF & _
"json-stable-stringify@1.0.1 [license(s): MIT]" & @CRLF & _
"package.json: MIT" & @CRLF & _
"license files: MIT" & @CRLF & _
"readme files: MIT" & @CRLF & _
"" & @CRLF & _
"json-stringify-safe@5.0.1 [license(s): ISC]" & @CRLF & _
"package.json: ISC" & @CRLF & _
"license files: ISC" & @CRLF & _
"" & @CRLF & _
"json5@0.4.0 [license(s): MIT]" & @CRLF & _
"package.json: MIT" & @CRLF & _
"readme files: MIT" & @CRLF & _
"" & @CRLF & _
"json5@0.5.1 [license(s): MIT]" & @CRLF & _
"package.json: MIT" & @CRLF & _
"license files: MIT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")