import Foundation
let pattern = #"\b@[\d.]*\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
jsesc@1.3.0 [license(s): MIT]
package.json: MIT
json-schema@0.2.3 [license(s): AFLv2.1, AFLv2.1/BSD, BSD]
package.json: AFLv2.1, AFLv2.1/BSD, BSD
readme files: BSD
json-schema-traverse@0.3.1 [license(s): MIT]
package.json: MIT
license files: MIT
json-stable-stringify@1.0.1 [license(s): MIT]
package.json: MIT
license files: MIT
readme files: MIT
json-stringify-safe@5.0.1 [license(s): ISC]
package.json: ISC
license files: ISC
json5@0.4.0 [license(s): MIT]
package.json: MIT
readme files: MIT
json5@0.5.1 [license(s): MIT]
package.json: MIT
license files: MIT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)