const regex = /\b@[\d.]*\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b@[\\d.]*\\d', 'g')
const str = `jsesc@1.3.0 [license(s): MIT]
package.json: MIT
json-schema@0.2.3 [license(s): AFLv2.1, AFLv2.1/BSD, BSD]
package.json: AFLv2.1, AFLv2.1/BSD, BSD
readme files: BSD
json-schema-traverse@0.3.1 [license(s): MIT]
package.json: MIT
license files: MIT
json-stable-stringify@1.0.1 [license(s): MIT]
package.json: MIT
license files: MIT
readme files: MIT
json-stringify-safe@5.0.1 [license(s): ISC]
package.json: ISC
license files: ISC
json5@0.4.0 [license(s): MIT]
package.json: MIT
readme files: MIT
json5@0.5.1 [license(s): MIT]
package.json: MIT
license files: MIT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}