$re = '/\b@[\d.]*\d/';
$str = 'jsesc@1.3.0 [license(s): MIT]
package.json: MIT
json-schema@0.2.3 [license(s): AFLv2.1, AFLv2.1/BSD, BSD]
package.json: AFLv2.1, AFLv2.1/BSD, BSD
readme files: BSD
json-schema-traverse@0.3.1 [license(s): MIT]
package.json: MIT
license files: MIT
json-stable-stringify@1.0.1 [license(s): MIT]
package.json: MIT
license files: MIT
readme files: MIT
json-stringify-safe@5.0.1 [license(s): ISC]
package.json: ISC
license files: ISC
json5@0.4.0 [license(s): MIT]
package.json: MIT
readme files: MIT
json5@0.5.1 [license(s): MIT]
package.json: MIT
license files: MIT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);