#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?!Mrs?\.|Jr\.|Dr\.|Sr\.|Prof\.)(\b\S+[.?!]["']?)\s"
Local $sString = "I works just fine for my purpose, but now I need the exact same regex in Javascript? (to make sure that the outputs are consistent) and I'm struggling to translate Mr. this Python regex. Into one compatible with Javascript. "What with Quoting?" Another sentence. " & @CRLF & _
""
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)