# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?!Mrs?\.|Jr\.|Dr\.|Sr\.|Prof\.)(\b\S+[.?!][\"']?)\s"
test_str = ("I works just fine for my purpose, but now I need the exact same regex in Javascript? (to make sure that the outputs are consistent) and I'm struggling to translate Mr. this Python regex. Into one compatible with Javascript. \"What with Quoting?\" Another sentence. \n")
subst = "$1\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.