import Foundation
let pattern = #"(?!Mrs?\.|Jr\.|Dr\.|Sr\.|Prof\.)(\b\S+[.?!]["']?)\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
I works just fine for my purpose, but now I need the exact same regex in Javascript? (to make sure that the outputs are consistent) and I'm struggling to translate Mr. this Python regex. Into one compatible with Javascript. "What with Quoting?" Another sentence.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)