$re = '/(?!Mrs?\.|Jr\.|Dr\.|Sr\.|Prof\.)(\b\S+[.?!]["\']?)\s/';
$str = 'I works just fine for my purpose, but now I need the exact same regex in Javascript? (to make sure that the outputs are consistent) and I\'m struggling to translate Mr. this Python regex. Into one compatible with Javascript. "What with Quoting?" Another sentence.
';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;