using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!Mrs?\.|Jr\.|Dr\.|Sr\.|Prof\.)(\b\S+[.?!][""']?)\s";
string substitution = @"$1\n";
string input = @"I works just fine for my purpose, but now I need the exact same regex in Javascript? (to make sure that the outputs are consistent) and I'm struggling to translate Mr. this Python regex. Into one compatible with Javascript. ""What with Quoting?"" Another sentence.
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}