#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ixD)(.*?)" & @CRLF & _
"" & @CRLF & _
"(?<=[.!?]|[.!?][\'"])" & @CRLF & _
"" & @CRLF & _
"(?<!" & @CRLF & _
"Mr\.|" & @CRLF & _
"Mrs\.|" & @CRLF & _
"Ms\.|" & @CRLF & _
"Jr\.|" & @CRLF & _
"Dr\.|" & @CRLF & _
"Prof\.|" & @CRLF & _
"Sr\.|" & @CRLF & _
"Ltd\.|" & @CRLF & _
"\s[A-Z]\.)" & @CRLF & _
"" & @CRLF & _
"\s+" & @CRLF & _
"" & @CRLF & _
""
Local $sString = "Start Date. Test. Test||. Test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")