re = /(.*?)
(?<=[.!?]|[.!?][\'"])
(?<!
Mr\.|
Mrs\.|
Ms\.|
Jr\.|
Dr\.|
Prof\.|
Sr\.|
Ltd\.|
\s[A-Z]\.)
\s+
/ix
str = 'Start Date. Test. Test||. Test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end