package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(.*?)
(?<=[.!?]|[.!?][\'"])
(?<!
Mr\.|
Mrs\.|
Ms\.|
Jr\.|
Dr\.|
Prof\.|
Sr\.|
Ltd\.|
\s[A-Z]\.)
\s+
`)
var str = `Start Date. Test. Test||. Test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}