import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)\n\n"
+ "(?<=[.!?]|[.!?][\\'\"])\n\n"
+ "(?<!\n"
+ "Mr\\.|\n"
+ "Mrs\\.|\n"
+ "Ms\\.|\n"
+ "Jr\\.|\n"
+ "Dr\\.|\n"
+ "Prof\\.|\n"
+ "Sr\\.|\n"
+ "Ltd\\.|\n"
+ "\\s[A-Z]\\.)\n\n"
+ "\\s+\n\n";
final String string = "Start Date. Test. Test||. Test";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}