// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ix)(.*?)
(?<=[.!?]|[.!?][\'"])
(?<!
Mr\.|
Mrs\.|
Ms\.|
Jr\.|
Dr\.|
Prof\.|
Sr\.|
Ltd\.|
\s[A-Z]\.)
\s+
"#).unwrap();
let string = "Start Date. Test. Test||. Test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}