import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Auseinandersetzung\\s*?(?:<\\/?[^>]*?>)?\\s*?mit\\s*?(?:<\\/?[^>]*?>)?\\s*?cement\\s*?(?:<\\/?[^>]*?>)?\\s*?hat\\s*?(?:<\\/?[^>]*?>)?\\s*?erneut\\s*?(?:<\\/?[^>]*?>)?\\s*?zu\\s*?(?:<\\/?[^>]*?>)?\\s*?Debatten";
final String string = "Es geht um das sogenannte Human Enhancement. Unter dem sperrigen Begriff wird der Versuch verstanden, die Grenzen des menschlichen Geistes und Körpers mithilfe von Technik vorübergehend oder dauerhaft zu überwinden. Die geistes– und sozialwissenschaftliche Auseinandersetzung mit <em>cement</em> hat erneut zu Debatten über den Status des Menschen als Cyborg geführt. Nicht nur das. Auf dem Prüfstand steht inzwischen der Humanismus. Ist diese Idee noch zu retten?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}