re = /Auseinandersetzung\s*?(?:<\/?[^>]*?>)?\s*?mit\s*?(?:<\/?[^>]*?>)?\s*?cement\s*?(?:<\/?[^>]*?>)?\s*?hat\s*?(?:<\/?[^>]*?>)?\s*?erneut\s*?(?:<\/?[^>]*?>)?\s*?zu\s*?(?:<\/?[^>]*?>)?\s*?Debatten/
str = 'Es geht um das sogenannte Human Enhancement. Unter dem sperrigen Begriff wird der Versuch verstanden, die Grenzen des menschlichen Geistes und Körpers mithilfe von Technik vorübergehend oder dauerhaft zu überwinden. Die geistes– und sozialwissenschaftliche Auseinandersetzung mit <em>cement</em> hat erneut zu Debatten über den Status des Menschen als Cyborg geführt. Nicht nur das. Auf dem Prüfstand steht inzwischen der Humanismus. Ist diese Idee noch zu retten?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end