import Foundation
let pattern = #"Auseinandersetzung\s*?(?:<\/?[^>]*?>)?\s*?mit\s*?(?:<\/?[^>]*?>)?\s*?cement\s*?(?:<\/?[^>]*?>)?\s*?hat\s*?(?:<\/?[^>]*?>)?\s*?erneut\s*?(?:<\/?[^>]*?>)?\s*?zu\s*?(?:<\/?[^>]*?>)?\s*?Debatten"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Es geht um das sogenannte Human Enhancement. Unter dem sperrigen Begriff wird der Versuch verstanden, die Grenzen des menschlichen Geistes und Körpers mithilfe von Technik vorübergehend oder dauerhaft zu überwinden. Die geistes– und sozialwissenschaftliche Auseinandersetzung mit <em>cement</em> hat erneut zu Debatten über den Status des Menschen als Cyborg geführt. Nicht nur das. Auf dem Prüfstand steht inzwischen der Humanismus. Ist diese Idee noch zu retten?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)