const regex = /Auseinandersetzung\s*?(?:<\/?[^>]*?>)?\s*?mit\s*?(?:<\/?[^>]*?>)?\s*?cement\s*?(?:<\/?[^>]*?>)?\s*?hat\s*?(?:<\/?[^>]*?>)?\s*?erneut\s*?(?:<\/?[^>]*?>)?\s*?zu\s*?(?:<\/?[^>]*?>)?\s*?Debatten/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Auseinandersetzung\\s*?(?:<\\\/?[^>]*?>)?\\s*?mit\\s*?(?:<\\\/?[^>]*?>)?\\s*?cement\\s*?(?:<\\\/?[^>]*?>)?\\s*?hat\\s*?(?:<\\\/?[^>]*?>)?\\s*?erneut\\s*?(?:<\\\/?[^>]*?>)?\\s*?zu\\s*?(?:<\\\/?[^>]*?>)?\\s*?Debatten', 'g')
const str = `Es geht um das sogenannte Human Enhancement. Unter dem sperrigen Begriff wird der Versuch verstanden, die Grenzen des menschlichen Geistes und Körpers mithilfe von Technik vorübergehend oder dauerhaft zu überwinden. Die geistes– und sozialwissenschaftliche Auseinandersetzung mit <em>cement</em> hat erneut zu Debatten über den Status des Menschen als Cyborg geführt. Nicht nur das. Auf dem Prüfstand steht inzwischen der Humanismus. Ist diese Idee noch zu retten?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}