use strict;
my $str = 'Es geht um das sogenannte Human Enhancement. Unter dem sperrigen Begriff wird der Versuch verstanden, die Grenzen des menschlichen Geistes und Körpers mithilfe von Technik vorübergehend oder dauerhaft zu überwinden. Die geistes– und sozialwissenschaftliche Auseinandersetzung mit <em>cement</em> hat erneut zu Debatten über den Status des Menschen als Cyborg geführt. Nicht nur das. Auf dem Prüfstand steht inzwischen der Humanismus. Ist diese Idee noch zu retten?';
my $regex = qr/Auseinandersetzung\s*?(?:<\/?[^>]*?>)?\s*?mit\s*?(?:<\/?[^>]*?>)?\s*?cement\s*?(?:<\/?[^>]*?>)?\s*?hat\s*?(?:<\/?[^>]*?>)?\s*?erneut\s*?(?:<\/?[^>]*?>)?\s*?zu\s*?(?:<\/?[^>]*?>)?\s*?Debatten/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}