#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/{2}.*|\/\*.*\*\/$"
Local $sString = "<script>" & @CRLF & _
"" & @CRLF & _
"// This is a comment" & @CRLF & _
"/* This is another comment */" & @CRLF & _
"" & @CRLF & _
"// The following is not a comment" & @CRLF & _
"var src="//google.com"; " & @CRLF & _
"" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")