re = /^\/{2}.*|\/\*.*\*\/$/m
str = '<script>
// This is a comment
/* This is another comment */
// The following is not a comment
var src="//google.com";
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end