import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/{2}.*|\\/\\*.*\\*\\/$";
final String string = "<script>\n\n"
+ "// This is a comment\n"
+ "/* This is another comment */\n\n"
+ "// The following is not a comment\n"
+ "var src=\"//google.com\"; \n\n"
+ "</script>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}