package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/{2}.*|\/\*.*\*\/$`)
var str = `<script>
// This is a comment
/* This is another comment */
// The following is not a comment
var src="//google.com";
</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}